What’s Vulnerable › Vulnerabilities
CVE-2020-16289
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-08-13 · updated 2026-06-17
- Weakness: CWE-787
Description
A buffer overflow vulnerability in cif_print_page() in devices/gdevcif.c of Artifex Software GhostScript v9.50 allows a remote attacker to cause a denial of service via a crafted PDF file. This is fixed in v9.51.
Affected products
- Artifex Ghostscript: before 9.52 — fixed in 9.52
- Canonical Ubuntu Linux: 16.04, 18.04, 20.04
- Debian Linux: 9.0, 10.0
How to fix
Upgrade to a fixed version: Artifex Ghostscript 9.52. Check the vendor advisory for mitigations.
References
- https://bugs.ghostscript.com/show_bug.cgi?id=701788
- https://git.ghostscript.com/?p=ghostpdl.git%3Ba=commit%3Bh=d31e25ed5b130499e0d880e4609b1b4824699768
- https://lists.debian.org/debian-lts-announce/2020/08/msg00032.html
- https://security.gentoo.org/glsa/202008-20
- https://usn.ubuntu.com/4469-1/
- https://www.debian.org/security/2020/dsa-4748
- https://bugs.ghostscript.com/show_bug.cgi?id=701788
- https://git.ghostscript.com/?p=ghostpdl.git%3Ba=commit%3Bh=d31e25ed5b130499e0d880e4609b1b4824699768
- https://lists.debian.org/debian-lts-announce/2020/08/msg00032.html
- https://security.gentoo.org/glsa/202008-20
- https://usn.ubuntu.com/4469-1/
- https://www.debian.org/security/2020/dsa-4748
Get alerted when CVE-2020-16289 or the next vulnerability affects your stack