What’s Vulnerable › Vulnerabilities
CVE-2020-1690
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-07 · updated 2026-06-17
- Weakness: CWE-285
Description
An improper authorization flaw was discovered in openstack-selinux's applied policy where it does not prevent a non-root user in a container from privilege escalation. A non-root attacker in one or more Red Hat OpenStack (RHOSP) containers could send messages to the dbus. With access to the dbus, the attacker could start or stop services, possibly causing a denial of service. Versions before openstack-selinux 0.8.24 are affected.
Affected products
- RedHat Openstack-Selinux: before 0.8.24 — fixed in 0.8.24
- nova_libvirt container provided by the Red Hat OpenStack Platform: 15.0, 16.1
How to fix
Upgrade to a fixed version: RedHat Openstack-Selinux 0.8.24. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1789640
- https://bugzilla.redhat.com/show_bug.cgi?id=1789640
Get alerted when CVE-2020-1690 or the next vulnerability affects your stack