What’s Vulnerable › Vulnerabilities
CVE-2020-1694
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-09-16 · updated 2026-06-17
- Weakness: CWE-183
Description
A flaw was found in all versions of Keycloak before 10.0.0, where the NodeJS adapter did not support the verify-token-audience. This flaw results in some users having access to sensitive information outside of their permissions.
Affected products
- Keycloak: before 10.0.0 — fixed in 10.0.0
How to fix
Upgrade to a fixed version: Keycloak 10.0.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1790759
- https://bugzilla.redhat.com/show_bug.cgi?id=1790759
Get alerted when CVE-2020-1694 or the next vulnerability affects your stack