What’s Vulnerable › Vulnerabilities
CVE-2020-1707
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-20 · updated 2026-06-17
- Weakness: CWE-732
Description
A vulnerability was found in all openshift/postgresql-apb 4.x.x versions prior to 4.3.0, where an insecure modification vulnerability in the /etc/passwd file was found in the container openshift/postgresql-apb. An attacker with access to the container could use this flaw to modify /etc/passwd and escalate their privileges.
Affected products
- Openshift: from 4.0 before 4.3 — fixed in 4.3
How to fix
Upgrade to a fixed version: Openshift 4.3. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-1707
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-1707
Get alerted when CVE-2020-1707 or the next vulnerability affects your stack