What’s Vulnerable › Vulnerabilities
CVE-2020-1711
- Severity: medium (CVSS 6.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-11 · updated 2026-06-17
- Weakness: CWE-122
Description
An out-of-bounds heap buffer access flaw was found in the way the iSCSI Block driver in QEMU versions 2.12.0 before 4.2.1 handled a response coming from an iSCSI server while checking the status of a Logical Address Block (LBA) in an iscsi_co_block_status() routine. A remote user could use this flaw to crash the QEMU process, resulting in a denial of service or potential execution of arbitrary code with privileges of the QEMU process on the host.
Affected products
- Debian Linux: 8.0, 9.0
- openSUSE Leap: 15.1
- QEMU: from 2.12.0 before 4.2.1 — fixed in 4.2.1
- Red Hat Enterprise Linux: 7.0, 8.0
- OpenStack: 10, 13
How to fix
Upgrade to a fixed version: QEMU 4.2.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00007.html
- https://access.redhat.com/errata/RHSA-2020:0669
- https://access.redhat.com/errata/RHSA-2020:0730
- https://access.redhat.com/errata/RHSA-2020:0731
- https://access.redhat.com/errata/RHSA-2020:0773
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-1711
- https://lists.debian.org/debian-lts-announce/2020/03/msg00017.html
- https://lists.debian.org/debian-lts-announce/2020/09/msg00013.html
- https://lists.gnu.org/archive/html/qemu-devel/2020-01/msg05535.html
- https://security.gentoo.org/glsa/202005-02
- https://usn.ubuntu.com/4283-1/
- https://www.openwall.com/lists/oss-security/2020/01/23/3
Get alerted when CVE-2020-1711 or the next vulnerability affects your stack