What’s Vulnerable › Vulnerabilities
CVE-2020-1720
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-17 · updated 2026-06-17
- Weakness: CWE-285
Description
A flaw was found in PostgreSQL's "ALTER ... DEPENDS ON EXTENSION", where sub-commands did not perform authorization checks. An authenticated attacker could use this flaw in certain configurations to perform drop objects such as function, triggers, et al., leading to database corruption. This issue affects PostgreSQL versions before 12.2, before 11.7, before 10.12 and before 9.6.17.
Affected products
- PostgreSQL: from 9.6 before 9.6.17; from 10.0 before 10.12; from 11.0 before 11.7; from 12.0 before 12.2 — fixed in 10.12, 11.7, 12.2, 9.6.17
- RedHat Decision Manager: 7.0
- Red Hat Enterprise Linux: 8.0
- RedHat Software Collections: all versions
How to fix
Upgrade to a fixed version: PostgreSQL 10.12, 11.7, 12.2, 9.6.17. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00043.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-1720
- https://www.postgresql.org/about/news/2011/
- http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00043.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-1720
- https://www.postgresql.org/about/news/2011/
Get alerted when CVE-2020-1720 or the next vulnerability affects your stack