What’s Vulnerable › Vulnerabilities
CVE-2020-1729
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-28 · updated 2026-06-17
- Weakness: CWE-863
Description
A flaw was found in SmallRye's API through version 1.6.1. The API can allow other code running within the application server to potentially obtain the ClassLoader, bypassing any permissions checks that should have been applied. The largest threat from this vulnerability is a threat to data confidentiality. This is fixed in SmallRye 1.6.2
Affected products
- SmallRye: before 1.6.2 — fixed in 1.6.2
How to fix
Upgrade to a fixed version: SmallRye 1.6.2. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1802444
- https://bugzilla.redhat.com/show_bug.cgi?id=1802444
Get alerted when CVE-2020-1729 or the next vulnerability affects your stack