What’s Vulnerable › Vulnerabilities
CVE-2020-1730
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-13 · updated 2026-06-17
- Weakness: CWE-476
Description
A flaw was found in libssh versions before 0.8.9 and before 0.9.4 in the way it handled AES-CTR (or DES ciphers if enabled) ciphers. The server or client could crash when the connection hasn't been fully initialized and the system tries to cleanup the ciphers when closing the connection. The biggest threat from this vulnerability is system availability.
Affected products
- Canonical Ubuntu Linux: 18.04, 19.10
- Fedoraproject Fedora: 31, 32
- libssh: from 0.8.0 before 0.8.9; from 0.9.0 before 0.9.4 — fixed in 0.8.9, 0.9.4
- NetApp Cloud Backup: all versions
- Oracle Corporation MySQL Workbench: through 8.0.21
- Red Hat Enterprise Linux: 8.0
How to fix
Upgrade to a fixed version: libssh 0.8.9, 0.9.4. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-1730
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/2A7BIFKUYIYKTY7FX4BEWVC2OHS5DPOU/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VLSWHBQ3EPKGTGLQNH554Z746BJ3C554/
- https://security.netapp.com/advisory/ntap-20200424-0001/
- https://usn.ubuntu.com/4327-1/
- https://www.libssh.org/security/advisories/CVE-2020-1730.txt
- https://www.oracle.com/security-alerts/cpuoct2020.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-1730
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/2A7BIFKUYIYKTY7FX4BEWVC2OHS5DPOU/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VLSWHBQ3EPKGTGLQNH554Z746BJ3C554/
- https://security.netapp.com/advisory/ntap-20200424-0001/
- https://usn.ubuntu.com/4327-1/
Get alerted when CVE-2020-1730 or the next vulnerability affects your stack