What’s Vulnerable › Vulnerabilities
CVE-2020-17354
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-15 · updated 2026-06-17
- Weakness: CWE-863
Description
LilyPond before 2.24 allows attackers to bypass the -dsafe protection mechanism via output-def-lookup or output-def-scope, as demonstrated by dangerous Scheme code in a .ly file that causes arbitrary code execution during conversion to a different file format. NOTE: in 2.24 and later versions, safe mode is removed, and the product no longer tries to block code execution when external files are used.
Affected products
- Lilypond: before 2.24.0 — fixed in 2.24.0
How to fix
Upgrade to a fixed version: Lilypond 2.24.0. Check the vendor advisory for mitigations.
References
- http://lilypond.org/doc/v2.18/Documentation/usage/command_002dline-usage
- https://gitlab.com/lilypond/lilypond/-/merge_requests/1522
- https://lilypond.org/download.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/K43PF6VGFJNNGAPY57BW3VMEFFOSMRLF/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ST5BLLQ4GDME3SN7UE5OMNE5GZE66X4Y/
- https://phabricator.wikimedia.org/T259210
- https://tracker.debian.org/news/1249694/accepted-lilypond-2221-1-source-into-unstable/
- https://www.mediawiki.org/wiki/Extension:Score/2021_security_advisory
- http://lilypond.org/doc/v2.18/Documentation/usage/command_002dline-usage
- https://gitlab.com/lilypond/lilypond/-/merge_requests/1522
- https://lilypond.org/download.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/K43PF6VGFJNNGAPY57BW3VMEFFOSMRLF/
Get alerted when CVE-2020-17354 or the next vulnerability affects your stack