What’s Vulnerable › Vulnerabilities
CVE-2020-1736
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-03-16 · updated 2026-06-17
- Weakness: CWE-732
Description
A flaw was found in Ansible Engine when a file is moved using atomic_move primitive as the file mode cannot be specified. This sets the destination files world-readable if the destination file does not exist and if the file exists, the file could be changed to have less restrictive permissions before the move. This could lead to the disclosure of sensitive data. All versions in 2.7.x, 2.8.x and 2.9.x branches are believed to be vulnerable.
Affected products
- Fedoraproject Fedora: 31, 32
- Red Hat Ansible: through 2.7.16; from 2.8.0 before 2.8.15; from 2.9.0 before 2.9.13 — fixed in 2.8.15, 2.9.13
- Tower: through 3.3.4; from 3.3.5 through 3.4.5; from 3.5.0 through 3.5.5; from 3.6.0 through 3.6.3; from 3.7.0 through 3.7.2
- Red Hat CloudForms: 5.0
- OpenStack: 13
How to fix
Upgrade to a fixed version: Red Hat Ansible 2.8.15, 2.9.13. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-1736
- https://github.com/ansible/ansible/issues/67794
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/2NYYQP2XJB2TTRP6AKWVMBSPB2DFJNKD/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BPNZWBAUP4ZHUR6PO7U6ZXEKNCX62KZ7/
- https://security.gentoo.org/glsa/202006-11
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-1736
- https://github.com/ansible/ansible/issues/67794
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/2NYYQP2XJB2TTRP6AKWVMBSPB2DFJNKD/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BPNZWBAUP4ZHUR6PO7U6ZXEKNCX62KZ7/
- https://security.gentoo.org/glsa/202006-11
Get alerted when CVE-2020-1736 or the next vulnerability affects your stack