What’s Vulnerable › Vulnerabilities
CVE-2020-17390
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-25 · updated 2026-06-17
- Weakness: CWE-125
Description
This vulnerability allows local attackers to escalate privileges on affected installations of Parallels Desktop 15.1.2-47123. An attacker must first obtain the ability to execute low-privileged code on the target system in order to exploit this vulnerability. The specific flaw exists within the hypervisor kernel extension. The issue results from the lack of proper validation of user-supplied data, which can result in a read past the end of an allocated buffer. An attacker can leverage this vulnerability to escalate privileges and execute code in the context of the hypervisor. Was ZDI-CAN-10030.
Affected products
- Parallels Desktop: before 15.1.4 — fixed in 15.1.4
How to fix
Upgrade to a fixed version: Parallels Desktop 15.1.4. Check the vendor advisory for mitigations.
References
- https://kb.parallels.com/en/125013
- https://www.zerodayinitiative.com/advisories/ZDI-20-1008/
- https://kb.parallels.com/en/125013
- https://www.zerodayinitiative.com/advisories/ZDI-20-1008/
Get alerted when CVE-2020-17390 or the next vulnerability affects your stack