What’s Vulnerable › Vulnerabilities
CVE-2020-17406
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-10-13 · updated 2026-06-17
- Weakness: CWE-78
Description
This vulnerability allows remote attackers to execute arbitrary code on affected installations of Microhard Bullet-LTE prior to v1.2.0-r1112. Authentication is required to exploit this vulnerability. The specific flaw exists within the handling of the ping parameter provided to tools.sh. The issue results from the lack of proper validation of a user-supplied string before using it to execute a system call. An attacker can leverage this vulnerability to execute code in the context of root. Was ZDI-CAN-10595.
Affected products
- Microhard Bullet-LTE: before 1.2.0-r1112 — fixed in 1.2.0-r1112
How to fix
Upgrade to a fixed version: Microhard Bullet-LTE 1.2.0-r1112. Check the vendor advisory for mitigations.
References
- https://www.zerodayinitiative.com/advisories/ZDI-20-1205/
- https://www.zerodayinitiative.com/advisories/ZDI-20-1205/
Get alerted when CVE-2020-17406 or the next vulnerability affects your stack