What’s Vulnerable › Vulnerabilities
CVE-2020-17446
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-12 · updated 2026-06-17
- Weakness: CWE-824
Description
asyncpg before 0.21.0 allows a malicious PostgreSQL server to trigger a crash or execute arbitrary code (on a database client) via a crafted server response, because of access to an uninitialized pointer in the array data decoder.
Affected products
- Debian Linux: 9.0
- Magic Asyncpg: before 0.21.0 — fixed in 0.21.0
How to fix
Upgrade to a fixed version: Magic Asyncpg 0.21.0. Check the vendor advisory for mitigations.
References
- https://github.com/MagicStack/asyncpg/releases/tag/v0.21.0
- https://lists.debian.org/debian-lts-announce/2020/09/msg00002.html
- https://github.com/MagicStack/asyncpg/releases/tag/v0.21.0
- https://lists.debian.org/debian-lts-announce/2020/09/msg00002.html
Get alerted when CVE-2020-17446 or the next vulnerability affects your stack