What’s Vulnerable › Vulnerabilities

CVE-2020-1746

Description

A flaw was found in the Ansible Engine affecting Ansible Engine versions 2.7.x before 2.7.17 and 2.8.x before 2.8.11 and 2.9.x before 2.9.7 as well as Ansible Tower before and including versions 3.4.5 and 3.5.5 and 3.6.3 when the ldap_attr and ldap_entry community modules are used. The issue discloses the LDAP bind password to stdout or a log file if a playbook task is written using the bind_pw in the parameters field. The highest threat from this vulnerability is data confidentiality.

Affected products

How to fix

Upgrade to a fixed version: RedHat Ansible Engine 2.7.17, 2.8.11, 2.9.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-1746 or the next vulnerability affects your stack