What’s Vulnerable › Vulnerabilities
CVE-2020-17480
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-08-10 · updated 2026-06-17
- Weakness: CWE-79
Description
TinyMCE before 4.9.7 and 5.x before 5.1.4 allows XSS in the core parser, the paste plugin, and the visualchars plugin by using the clipboard or APIs to insert content into the editor.
Affected products
- tinymce: before 4.9.7; from 5.0.0 before 5.1.4 — fixed in 4.9.7, 5.1.4
How to fix
Upgrade to a fixed version: tinymce 4.9.7, 5.1.4. Check the vendor advisory for mitigations.
References
- https://github.com/tinymce/tinymce/security/advisories/GHSA-27gm-ghr9-4v95
- https://www.tiny.cloud/docs/release-notes/release-notes514/#securityfixes
- https://github.com/tinymce/tinymce/security/advisories/GHSA-27gm-ghr9-4v95
- https://www.tiny.cloud/docs/release-notes/release-notes514/#securityfixes
Get alerted when CVE-2020-17480 or the next vulnerability affects your stack