What’s Vulnerable › Vulnerabilities
CVE-2020-17504
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-01-08 · updated 2026-06-17
- Weakness: CWE-77
Description
The NDN-210 has a web administration panel which is made available over https. There is a command injection issue that will allow authenticated users to the administration panel to perform authenticated remote code execution. An issue exists in ngpsystemcmd.php in which the http parameters "x_modules" and "y_modules" are not properly handled. The NDN-210 is part of Barco TransForm N solution and this vulnerability is patched from TransForm N version 3.8 onwards.
Affected products
- Barco Transform N: before 3.8 — fixed in 3.8
How to fix
Upgrade to a fixed version: Barco Transform N 3.8. Check the vendor advisory for mitigations.
References
- https://www.barco.com/en/support/cms
- https://www.barco.com/en/support/knowledge-base/kb11589
- https://www.barco.com/en/support/transform-n-management-server
- https://www.barco.com/en/support/cms
- https://www.barco.com/en/support/knowledge-base/kb11589
- https://www.barco.com/en/support/transform-n-management-server
Get alerted when CVE-2020-17504 or the next vulnerability affects your stack