What’s Vulnerable › Vulnerabilities
CVE-2020-17513
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-14 · updated 2026-06-17
- Weakness: CWE-918
Description
In Apache Airflow versions prior to 1.10.13, the Charts and Query View of the old (Flask-admin based) UI were vulnerable for SSRF attack.
Affected products
- Apache Airflow: before 1.10.13 — fixed in 1.10.13
How to fix
Upgrade to a fixed version: Apache Airflow 1.10.13. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread.html/rb3647269f07cc2775ca6568cbfd4994d862c842a58120d2aba9c658a%40%3Cusers.airflow.apache.org%3E
- https://lists.apache.org/thread.html/rb3647269f07cc2775ca6568cbfd4994d862c842a58120d2aba9c658a%40%3Cusers.airflow.apache.org%3E
Get alerted when CVE-2020-17513 or the next vulnerability affects your stack