What’s Vulnerable › Vulnerabilities

CVE-2020-17515

Description

The "origin" parameter passed to some of the endpoints like '/trigger' was vulnerable to XSS exploit. This issue affects Apache Airflow versions prior to 1.10.13. This is same as CVE-2020-13944 but the implemented fix in Airflow 1.10.13 did not fix the issue completely.

Affected products

How to fix

Upgrade to a fixed version: Apache Airflow 1.10.15, 2.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-17515 or the next vulnerability affects your stack