What’s Vulnerable › Vulnerabilities
CVE-2020-17526
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 23.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-12-21 · updated 2026-06-17
Description
Incorrect Session Validation in Apache Airflow Webserver versions prior to 1.10.14 with default config allows a malicious airflow user on site A where they log in normally, to access unauthorized Airflow Webserver on Site B through the session from Site A. This does not affect users who have changed the default value for `[webserver] secret_key` config.
Affected products
- Apache Airflow: before 1.10.14 — fixed in 1.10.14
How to fix
Upgrade to a fixed version: Apache Airflow 1.10.14. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2020/12/21/1
- https://lists.apache.org/thread.html/r466759f377651f0a690475d5a52564d0e786e82c08d5a5730a4f8352%40%3Cannounce.apache.org%3E
- https://lists.apache.org/thread.html/rbeeb73a6c741f2f9200d83b9c2220610da314810c4e8c9cf881d47ef%40%3Cusers.airflow.apache.org%3E
- http://www.openwall.com/lists/oss-security/2020/12/21/1
- https://lists.apache.org/thread.html/r466759f377651f0a690475d5a52564d0e786e82c08d5a5730a4f8352%40%3Cannounce.apache.org%3E
- https://lists.apache.org/thread.html/rbeeb73a6c741f2f9200d83b9c2220610da314810c4e8c9cf881d47ef%40%3Cusers.airflow.apache.org%3E
Get alerted when CVE-2020-17526 or the next vulnerability affects your stack