What’s Vulnerable › Vulnerabilities
CVE-2020-17532: Apache ServiceComb Yaml remote deserialization vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-01-25 · updated 2026-06-17
- Weakness: CWE-20
Description
When handler-router component is enabled in servicecomb-java-chassis, authenticated user may inject some data and cause arbitrary code execution. The problem happens in versions between 2.0.0 ~ 2.1.3 and fixed in Apache ServiceComb-Java-Chassis 2.1.5
Affected products
- Apache Software Foundation Apache ServiceComb-Java-Chassis: from 2.0.0 before 2.1.5 — fixed in 2.1.5
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache ServiceComb-Java-Chassis 2.1.5. Check the vendor advisory for mitigations.
References
- https://issues.apache.org/jira/browse/SCB-2145
- https://seclists.org/oss-sec/2021/q1/60
- https://issues.apache.org/jira/browse/SCB-2145
- https://seclists.org/oss-sec/2021/q1/60
Get alerted when CVE-2020-17532 or the next vulnerability affects your stack