What’s Vulnerable › Vulnerabilities

CVE-2020-1755

Description

In Moodle before 3.8.2, 3.7.5, 3.6.9 and 3.5.11, X-Forwarded-For headers could be used to spoof a user's IP, in order to bypass remote address checks.

Affected products

How to fix

Upgrade to a fixed version: Moodle 3.5.11, 3.6.9, 3.7.5, 3.8.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-1755 or the next vulnerability affects your stack