What’s Vulnerable › Vulnerabilities
CVE-2020-1762
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-27 · updated 2026-06-17
- Weakness: CWE-384
Description
An insufficient JWT validation vulnerability was found in Kiali versions 0.4.0 to 1.15.0 and was fixed in Kiali version 1.15.1, wherein a remote attacker could abuse this flaw by stealing a valid JWT cookie and using that to spoof a user session, possibly gaining privileges to view and alter the Istio configuration.
Affected products
- kiali: from 0.4.0 before 1.15.1 — fixed in 1.15.1
- Red Hat OpenShift Service Mesh 2: 1.0
How to fix
Upgrade to a fixed version: kiali 1.15.1. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-1762
- https://kiali.io/news/security-bulletins/kiali-security-001/
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-1762
- https://kiali.io/news/security-bulletins/kiali-security-001/
Get alerted when CVE-2020-1762 or the next vulnerability affects your stack