What’s Vulnerable › Vulnerabilities
CVE-2020-1887
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-13 · updated 2026-06-17
- Weakness: CWE-297
Description
Incorrect validation of the TLS SNI hostname in osquery versions after 2.9.0 and before 4.2.0 could allow an attacker to MITM osquery traffic in the absence of a configured root chain of trust.
Affected products
- osquery: from 2.9.0 (excl.) before 4.2.0 — fixed in 4.2.0
How to fix
Upgrade to a fixed version: osquery 4.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/osquery/osquery/pull/6197
- https://www.facebook.com/security/advisories/cve-2020-1887
- https://github.com/osquery/osquery/pull/6197
- https://www.facebook.com/security/advisories/cve-2020-1887
Get alerted when CVE-2020-1887 or the next vulnerability affects your stack