What’s Vulnerable › Vulnerabilities
CVE-2020-18875
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-18 · updated 2026-06-17
- Weakness: CWE-74
Description
Incorrect Access Control in DotCMS versions before 5.1 allows remote attackers to gain privileges by injecting client configurations via vtl (velocity) files.
Affected products
- dotCMS core: before 5.1.0 — fixed in 5.1.0
How to fix
Upgrade to a fixed version: dotCMS core 5.1.0. Check the vendor advisory for mitigations.
References
- https://cwe.mitre.org/data/definitions/284.html
- https://dotcms.com/security/SI-51
- https://github.com/dotCMS/core/issues/15882
- https://cwe.mitre.org/data/definitions/284.html
- https://dotcms.com/security/SI-51
- https://github.com/dotCMS/core/issues/15882
Get alerted when CVE-2020-18875 or the next vulnerability affects your stack