What’s Vulnerable › Vulnerabilities
CVE-2020-1892
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-03 · updated 2026-06-17
- Weakness: CWE-125
Description
Insufficient boundary checks when decoding JSON in JSON_parser allows read access to out of bounds memory, potentially leading to information leak and DOS. This issue affects HHVM 4.45.0, 4.44.0, 4.43.0, 4.42.0, 4.41.0, 4.40.0, 4.39.0, versions between 4.33.0 and 4.38.0 (inclusive), versions between 4.9.0 and 4.32.0 (inclusive), and versions prior to 4.8.7.
Affected products
- Facebook HHVM: before 4.8.7; from 4.9.0 through 4.32.0; from 4.33.0 through 4.38.0; 4.39.0, 4.40.0, 4.41.0, 4.42.0, 4.43.0, 4.44.0 (+1) — fixed in 4.8.7
How to fix
Upgrade to a fixed version: Facebook HHVM 4.8.7. Check the vendor advisory for mitigations.
References
- https://github.com/facebook/hhvm/commit/dabd48caf74995e605f1700344f1ff4a5d83441d
- https://hhvm.com/blog/2020/02/20/security-update.html
- https://github.com/facebook/hhvm/commit/dabd48caf74995e605f1700344f1ff4a5d83441d
- https://hhvm.com/blog/2020/02/20/security-update.html
Get alerted when CVE-2020-1892 or the next vulnerability affects your stack