What’s Vulnerable › Vulnerabilities
CVE-2020-19203
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-12 · updated 2026-06-17
- Weakness: CWE-79
Description
An authenticated Cross-Site Scripting (XSS) vulnerability was found in widgets/widgets/wake_on_lan_widget.php, a component of the pfSense software WebGUI, on version 2.4.4-p2 and earlier. The widget did not encode the descr (description) parameter of wake-on-LAN entries in its output, leading to a possible stored XSS.
Affected products
- Netgate pfSense: before 2.4.4; 2.4.4, 2.4.4-p1, 2.4.4-p2 — fixed in 2.4.4
How to fix
Upgrade to a fixed version: Netgate pfSense 2.4.4. Check the vendor advisory for mitigations.
References
- https://docs.netgate.com/pfsense/en/latest/releases/2-4-4-p3.html
- https://gist.github.com/dharmeshbaskaran/55d546496bfb0ba28117e846d8b785db
- https://www.netgate.com/assets/downloads/advisories/pfSense-SA-19_04.webgui.asc
- https://www.pfsense.org/download/
- https://docs.netgate.com/pfsense/en/latest/releases/2-4-4-p3.html
- https://gist.github.com/dharmeshbaskaran/55d546496bfb0ba28117e846d8b785db
- https://www.netgate.com/assets/downloads/advisories/pfSense-SA-19_04.webgui.asc
- https://www.pfsense.org/download/
Get alerted when CVE-2020-19203 or the next vulnerability affects your stack