What’s Vulnerable › Vulnerabilities
CVE-2020-1931
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-30 · updated 2026-06-17
- Weakness: CWE-78
Description
A command execution issue was found in Apache SpamAssassin prior to 3.4.3. Carefully crafted nefarious Configuration (.cf) files can be configured to run system commands similar to CVE-2018-11805. This issue is less stealthy and attempts to exploit the issue will throw warnings. Thanks to Damian Lukowski at credativ for reporting the issue ethically. With this bug unpatched, exploits can be injected in a number of scenarios though doing so remotely is difficult. In addition to upgrading to SA 3.4.4, we again recommend that users should only use update channels or 3rd party .cf files from trusted places.
Affected products
- Apache Software Foundation Apache SpamAssassin: before 3.4.3 — fixed in 3.4.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache SpamAssassin 3.4.3. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00003.html
- https://bz.apache.org/SpamAssassin/show_bug.cgi?id=7784
- https://lists.debian.org/debian-lts-announce/2020/02/msg00015.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/B7SY2LUSH2X3IUXN4EQQ5A6QVUFYIV3D/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VOVVKFP2G2AF5GHAB4WMHOEX76A3H6CE/
- https://seclists.org/bugtraq/2020/Feb/1
- https://usn.ubuntu.com/4265-1/
- https://usn.ubuntu.com/4265-2/
- https://www.debian.org/security/2020/dsa-4615
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00003.html
- https://bz.apache.org/SpamAssassin/show_bug.cgi?id=7784
- https://lists.debian.org/debian-lts-announce/2020/02/msg00015.html
Get alerted when CVE-2020-1931 or the next vulnerability affects your stack