What’s Vulnerable › Vulnerabilities
CVE-2020-19316
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-20 · updated 2026-06-17
- Weakness: CWE-78
Description
OS Command injection vulnerability in function link in Filesystem.php in Laravel Framework before 5.8.17.
Affected products
- Laravel Framework: before 5.8.17 — fixed in 5.8.17
How to fix
Upgrade to a fixed version: Laravel Framework 5.8.17. Check the vendor advisory for mitigations.
References
- http://www.netbytesec.com/advisories/OSCommandInjectionInLaravelFramework/
- https://github.com/laravel/framework/commit/44c3feb604944599ad1c782a9942981c3991fa31
- http://www.netbytesec.com/advisories/OSCommandInjectionInLaravelFramework/
- https://github.com/laravel/framework/commit/44c3feb604944599ad1c782a9942981c3991fa31
Get alerted when CVE-2020-19316 or the next vulnerability affects your stack