What’s Vulnerable › Vulnerabilities
CVE-2020-19692
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-04 · updated 2026-06-17
- Weakness: CWE-120
Description
Buffer Overflow vulnerabilty found in Nginx NJS v.0feca92 allows a remote attacker to execute arbitrary code via the njs_module_read in the njs_module.c file.
Affected products
- F5 Njs: before 0.3.4 — fixed in 0.3.4
How to fix
Upgrade to a fixed version: F5 Njs 0.3.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-19692 or the next vulnerability affects your stack