What’s Vulnerable › Vulnerabilities
CVE-2020-1979: PAN-OS: A format string vulnerability in PAN-OS log daemon (logd) on Panorama allows local privilege escalation
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-11 · updated 2026-06-17
- Weakness: CWE-134
Description
A format string vulnerability in the PAN-OS log daemon (logd) on Panorama allows a network based attacker with knowledge of registered firewall devices and access to Panorama management interfaces to execute arbitrary code, bypassing the restricted shell and escalating privileges. This issue affects only PAN-OS 8.1 versions earlier than PAN-OS 8.1.13 on Panorama. This issue does not affect PAN-OS 7.1, PAN-OS 9.0, or later PAN-OS versions.
Affected products
- Palo Alto Networks PAN-OS: before 8.1.13 — fixed in 8.1.13
- Palo Alto Networks PAN-OS: from 8.1 before 8.1.13 — fixed in 8.1.13
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 8.1.13; Palo Alto Networks PAN-OS 8.1.13. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2020-1979
- https://security.paloaltonetworks.com/CVE-2020-1979
Get alerted when CVE-2020-1979 or the next vulnerability affects your stack