What’s Vulnerable › Vulnerabilities
CVE-2020-1989: Global Protect Agent: Incorrect privilege assignment allows local privilege escalation
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-08 · updated 2026-06-17
- Weakness: CWE-266
Description
An incorrect privilege assignment vulnerability when writing application-specific files in the Palo Alto Networks Global Protect Agent for Linux on ARM platform allows a local authenticated user to gain root privileges on the system. This issue affects Palo Alto Networks Global Protect Agent for Linux 5.0 versions before 5.0.8; 5.1 versions before 5.1.1.
Affected products
- Palo Alto Networks GlobalProtect App: from 5.0 before 5.0.8; from 5.1 before 5.1.1 — fixed in 5.0.8, 5.1.1
- Palo Alto Networks GlobalProtect App: from 5.0 before 5.0.8; from 5.1 before 5.1.1 — fixed in 5.0.8, 5.1.1
How to fix
Upgrade to a fixed version: Palo Alto Networks GlobalProtect App 5.0.8, 5.1.1; Palo Alto Networks GlobalProtect App 5.0.8, 5.1.1. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2020-1989
- https://security.paloaltonetworks.com/CVE-2020-1989
Get alerted when CVE-2020-1989 or the next vulnerability affects your stack