What’s Vulnerable › Vulnerabilities
CVE-2020-2000: PAN-OS: OS command injection and memory corruption vulnerability
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-11-12 · updated 2026-06-17
- Weakness: CWE-20
Description
An OS command injection and memory corruption vulnerability in the PAN-OS management web interface that allows authenticated administrators to disrupt system processes and potentially execute arbitrary code and OS commands with root privileges. This issue impacts: PAN-OS 8.1 versions earlier than PAN-OS 8.1.16; PAN-OS 9.0 versions earlier than PAN-OS 9.0.10; PAN-OS 9.1 versions earlier than PAN-OS 9.1.4; PAN-OS 10.0 versions earlier than PAN-OS 10.0.1.
Affected products
- Palo Alto Networks PAN-OS: from 8.1.0 before 8.1.16; from 9.0.0 before 9.0.10; from 9.1.0 before 9.1.4; from 10.0.0 before 10.0.1 — fixed in 10.0.1, 8.1.16, 9.0.10, 9.1.4
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 10.0.1, 8.1.16, 9.0.10, 9.1.4. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2020-2000
- https://security.paloaltonetworks.com/CVE-2020-2000
Get alerted when CVE-2020-2000 or the next vulnerability affects your stack