What’s Vulnerable › Vulnerabilities
CVE-2020-2008: PAN-OS: OS command injection or arbitrary file deletion vulnerability
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-05-13 · updated 2026-06-17
- Weakness: CWE-73
Description
An OS command injection and external control of filename vulnerability in Palo Alto Networks PAN-OS allows authenticated administrators to execute code with root privileges or delete arbitrary system files and impact the system's integrity or cause a denial of service condition. This issue affects: All versions of PAN-OS 7.1 and 8.0; PAN-OS 8.1 versions earlier than 8.1.14.
Affected products
- Palo Alto Networks PAN-OS: from 7.1.0 through 7.1.26; from 8.0.0 through 8.0.20; from 8.1.0 through 8.1.13
- Palo Alto Networks PAN-OS: from 8.1 before 8.1.14; 8.0.*, 7.1.* — fixed in 8.1.14
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 8.1.14. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2020-2008
- https://security.paloaltonetworks.com/CVE-2020-2008
Get alerted when CVE-2020-2008 or the next vulnerability affects your stack