What’s Vulnerable › Vulnerabilities
CVE-2020-2010: PAN-OS: Authenticated user command injection vulnerability
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-05-13 · updated 2026-06-17
- Weakness: CWE-78
Description
An OS command injection vulnerability in PAN-OS management interface allows an authenticated administrator to execute arbitrary OS commands with root privileges. This issue affects: All versions of PAN-OS 7.1 and 8.0; PAN-OS 8.1 versions earlier than 8.1.14; PAN-OS 9.0 versions earlier than 9.0.7.
Affected products
- Palo Alto Networks PAN-OS: from 7.1.0 through 7.1.26; from 8.0.0 through 8.0.20; from 8.1.0 through 8.1.13; from 9.0.0 through 9.0.6
- Palo Alto Networks PAN-OS: from 9.0 before 9.0.7; from 8.1 before 8.1.14; 8.0.*, 7.1.* — fixed in 9.0.7, 8.1.14
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 9.0.7, 8.1.14. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2020-2010
- https://security.paloaltonetworks.com/CVE-2020-2010
Get alerted when CVE-2020-2010 or the next vulnerability affects your stack