What’s Vulnerable › Vulnerabilities
CVE-2020-2011: PAN-OS: Panorama registration denial of service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-05-13 · updated 2026-06-17
- Weakness: CWE-20
Description
An improper input validation vulnerability in the configuration daemon of Palo Alto Networks PAN-OS Panorama allows for a remote unauthenticated user to send a specifically crafted registration request to the device that causes the configuration service to crash. Repeated attempts to send this request result in denial of service to all PAN-OS Panorama services by restarting the device and putting it into maintenance mode. This issue affects: All versions of PAN-OS 7.1, PAN-OS 8.0; PAN-OS 8.1 versions earlier than 8.1.14; PAN-OS 9.0 versions earlier than 9.0.7; PAN-OS 9.1 versions earlier than 9.1.0.
Affected products
- Palo Alto Networks PAN-OS: from 7.1.0 through 7.1.26; from 8.0.0 through 8.0.20; from 8.1.0 before 8.1.14; from 9.0.0 before 9.1.0 — fixed in 8.1.14, 9.1.0
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 8.1.14, 9.1.0. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2020-2011
- https://security.paloaltonetworks.com/CVE-2020-2011
Get alerted when CVE-2020-2011 or the next vulnerability affects your stack