What’s Vulnerable › Vulnerabilities
CVE-2020-20118
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-11 · updated 2026-07-09
- Weakness: CWE-120
Description
Buffer Overflow vulnerability in Avast AntiVirus before v.19.7 allows a local attacker to cause a denial of service via a crafted request to the aswSnx.sys driver.
Affected products
- Avast Antivirus: before 19.7 — fixed in 19.7
How to fix
Upgrade to a fixed version: Avast Antivirus 19.7. Check the vendor advisory for mitigations.
References
- https://gitlab.com/yongchuank/avast-aswsnx-ioctl-82ac0060-oob-write
- https://gitlab.com/yongchuank/avast-aswsnx-ioctl-82ac0060-oob-write
Get alerted when CVE-2020-20118 or the next vulnerability affects your stack