What’s Vulnerable › Vulnerabilities

CVE-2020-2017: PAN-OS: DOM-Based cross site scripting vulnerability in management web interface

Description

A DOM-Based Cross Site Scripting Vulnerability exists in PAN-OS and Panorama Management Web Interfaces. A remote attacker able to convince an authenticated administrator to click on a crafted link to PAN-OS and Panorama Web Interfaces could execute arbitrary JavaScript code in the administrator's browser and perform administrative actions. This issue affects: PAN-OS 7.1 versions earlier than 7.1.26; PAN-OS 8.1 versions earlier than 8.1.13; PAN-OS 9.0 versions earlier than 9.0.6; All versions of PAN-OS 8.0.

Affected products

How to fix

Upgrade to a fixed version: Palo Alto Networks PAN-OS 7.1.26, 8.1.13, 9.0.6; Palo Alto Networks PAN-OS 7.1.26, 8.1.13, 9.0.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-2017 or the next vulnerability affects your stack