What’s Vulnerable › Vulnerabilities
CVE-2020-2023: Kata Containers - Containers have access to the guest root filesystem device
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-10 · updated 2026-06-17
- Weakness: CWE-250
Description
Kata Containers doesn't restrict containers from accessing the guest's root filesystem device. Malicious containers can exploit this to gain code execution on the guest and masquerade as the kata-agent. This issue affects Kata Containers 1.11 versions earlier than 1.11.1; Kata Containers 1.10 versions earlier than 1.10.5; and Kata Containers 1.9 and earlier versions.
Affected products
- Katacontainers Runtime: through 1.9; from 1.10 before 1.10.5; from 1.11 before 1.11.1 — fixed in 1.10.5, 1.11.1
How to fix
Upgrade to a fixed version: Katacontainers Runtime 1.10.5, 1.11.1. Check the vendor advisory for mitigations.
References
- https://github.com/kata-containers/agent/issues/791
- https://github.com/kata-containers/agent/pull/792
- https://github.com/kata-containers/runtime/issues/2488
- https://github.com/kata-containers/runtime/pull/2477
- https://github.com/kata-containers/runtime/pull/2487
- https://github.com/kata-containers/runtime/releases/tag/1.10.5
- https://github.com/kata-containers/runtime/releases/tag/1.11.1
- https://github.com/kata-containers/agent/issues/791
- https://github.com/kata-containers/agent/pull/792
- https://github.com/kata-containers/runtime/issues/2488
- https://github.com/kata-containers/runtime/pull/2477
- https://github.com/kata-containers/runtime/pull/2487
Get alerted when CVE-2020-2023 or the next vulnerability affects your stack