What’s Vulnerable › Vulnerabilities
CVE-2020-2024: Kata Containers - Guests can trick the kata-runtime into unmounting any mount point on the host
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-05-19 · updated 2026-06-17
- Weakness: CWE-59
Description
An improper link resolution vulnerability affects Kata Containers versions prior to 1.11.0. Upon container teardown, a malicious guest can trick the kata-runtime into unmounting any mount point on the host and all mount points underneath it, potentiality resulting in a host DoS.
Affected products
- Katacontainers Runtime: before 1.11.0 — fixed in 1.11.0
How to fix
Upgrade to a fixed version: Katacontainers Runtime 1.11.0. Check the vendor advisory for mitigations.
References
- https://github.com/kata-containers/runtime/issues/2474
- https://github.com/kata-containers/runtime/pull/2475
- https://github.com/kata-containers/runtime/issues/2474
- https://github.com/kata-containers/runtime/pull/2475
Get alerted when CVE-2020-2024 or the next vulnerability affects your stack