What’s Vulnerable › Vulnerabilities
CVE-2020-2025: Kata Containers - Cloud Hypervisor guests persist filesystem changes to the underlying host image file
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-05-19 · updated 2026-06-17
- Weakness: CWE-284
Description
Kata Containers before 1.11.0 on Cloud Hypervisor persists guest filesystem changes to the underlying image file on the host. A malicious guest can overwrite the image file to gain control of all subsequent guest VMs. Since Kata Containers uses the same VM image file with all VMMs, this issue may also affect QEMU and Firecracker based guests.
Affected products
- Katacontainers Runtime: before 1.11.0 — fixed in 1.11.0
How to fix
Upgrade to a fixed version: Katacontainers Runtime 1.11.0. Check the vendor advisory for mitigations.
References
- https://github.com/kata-containers/runtime/pull/2487
- https://github.com/kata-containers/runtime/pull/2487
Get alerted when CVE-2020-2025 or the next vulnerability affects your stack