What’s Vulnerable › Vulnerabilities
CVE-2020-2027: PAN-OS: Buffer overflow in authd authentication response
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-10 · updated 2026-06-17
- Weakness: CWE-121
Description
A buffer overflow vulnerability in the authd component of the PAN-OS management server allows authenticated administrators to disrupt system processes and potentially execute arbitrary code with root privileges. This issue affects: All versions of PAN-OS 7.1 and PAN-OS 8.0; PAN-OS 8.1 versions earlier than PAN-OS 8.1.13; PAN-OS 9.0 versions earlier than PAN-OS 9.0.7.
Affected products
- Palo Alto Networks PAN-OS: from 7.1.0 through 7.1.26; from 8.0.0 through 8.0.20; from 8.1.0 before 8.1.13; from 9.0.0 before 9.0.7 — fixed in 8.1.13, 9.0.7
- Palo Alto Networks PAN-OS: from 8.1 before 8.1.13; from 9.0 before 9.0.7; 7.1.*, 8.0.* — fixed in 8.1.13, 9.0.7
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 8.1.13, 9.0.7; Palo Alto Networks PAN-OS 8.1.13, 9.0.7. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2020-2027
- https://security.paloaltonetworks.com/CVE-2020-2027
Get alerted when CVE-2020-2027 or the next vulnerability affects your stack