What’s Vulnerable › Vulnerabilities
CVE-2020-2029: PAN-OS: OS command injection vulnerability in management interface certificate generator
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-10 · updated 2026-06-17
- Weakness: CWE-78
Description
An OS Command Injection vulnerability in the PAN-OS web management interface allows authenticated administrators to execute arbitrary OS commands with root privileges by sending a malicious request to generate new certificates for use in the PAN-OS configuration. This issue affects: All versions of PAN-OS 8.0; PAN-OS 7.1 versions earlier than PAN-OS 7.1.26; PAN-OS 8.1 versions earlier than PAN-OS 8.1.13.
Affected products
- Palo Alto Networks PAN-OS: from 7.1.0 before 7.1.26; from 8.0.0 through 8.0.20; from 8.1.0 before 8.1.13 — fixed in 7.1.26, 8.1.13
- Palo Alto Networks PAN-OS: from 7.1 before 7.1.26; from 8.1 before 8.1.13; 8.0.* — fixed in 7.1.26, 8.1.13
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 7.1.26, 8.1.13; Palo Alto Networks PAN-OS 7.1.26, 8.1.13. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2020-2029
- https://security.paloaltonetworks.com/CVE-2020-2029
Get alerted when CVE-2020-2029 or the next vulnerability affects your stack