What’s Vulnerable › Vulnerabilities
CVE-2020-2030: PAN-OS: OS command injection vulnerability in the management interface
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-07-08 · updated 2026-06-17
- Weakness: CWE-78
Description
An OS Command Injection vulnerability in the PAN-OS management interface that allows authenticated administrators to execute arbitrary OS commands with root privileges. This issue impacts PAN-OS 8.1 versions earlier than PAN-OS 8.1.15; and all versions of PAN-OS 7.1 and PAN-OS 8.0. This issue does not impact PAN-OS 9.0, PAN-OS 9.1, or Prisma Access services.
Affected products
- Palo Alto Networks PAN-OS: from 7.1.0 through 7.1.26; from 8.0.0 through 8.0.20; from 8.1.0 before 8.1.15 — fixed in 8.1.15
- Palo Alto Networks PAN-OS: from 8.1 before 8.1.15; 8.0.*, 7.1.* — fixed in 8.1.15
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 8.1.15; Palo Alto Networks PAN-OS 8.1.15. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2020-2030
- https://security.paloaltonetworks.com/CVE-2020-2030
Get alerted when CVE-2020-2030 or the next vulnerability affects your stack