What’s Vulnerable › Vulnerabilities
CVE-2020-2034: PAN-OS: OS command injection vulnerability in GlobalProtect portal
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-07-08 · updated 2026-06-17
- Weakness: CWE-78
Description
An OS Command Injection vulnerability in the PAN-OS GlobalProtect portal allows an unauthenticated network based attacker to execute arbitrary OS commands with root privileges. An attacker requires some knowledge of the firewall to exploit this issue. This issue can not be exploited if GlobalProtect portal feature is not enabled. This issue impacts PAN-OS 9.1 versions earlier than PAN-OS 9.1.3; PAN-OS 8.1 versions earlier than PAN-OS 8.1.15; PAN-OS 9.0 versions earlier than PAN-OS 9.0.9; all versions of PAN-OS 8.0 and PAN-OS 7.1. Prisma Access services are not impacted by this vulnerability.
Affected products
- Palo Alto Networks PAN-OS: from 7.1.0 through 7.1.26; from 8.0.0 through 8.0.20; from 8.1.0 before 8.1.15; from 9.0.0 before 9.0.9; from 9.1.0 before 9.1.3 — fixed in 8.1.15, 9.0.9, 9.1.3
- Palo Alto Networks PAN-OS: from 9.1 before 9.1.3; from 9.0 before 9.0.9; from 8.1 before 8.1.15; 8.0.*, 7.1.* — fixed in 9.1.3, 9.0.9, 8.1.15
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 8.1.15, 9.0.9, 9.1.3; Palo Alto Networks PAN-OS 9.1.3, 9.0.9, 8.1.15. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2020-2034
- https://security.paloaltonetworks.com/CVE-2020-2034
Get alerted when CVE-2020-2034 or the next vulnerability affects your stack