What’s Vulnerable › Vulnerabilities
CVE-2020-2036: PAN-OS: Reflected Cross-Site Scripting (XSS) vulnerability in management web interface
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 23.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-09-09 · updated 2026-06-17
- Weakness: CWE-79
Description
A reflected cross-site scripting (XSS) vulnerability exists in the PAN-OS management web interface. A remote attacker able to convince an administrator with an active authenticated session on the firewall management interface to click on a crafted link to that management web interface could potentially execute arbitrary JavaScript code in the administrator's browser and perform administrative actions. This issue impacts: PAN-OS 8.1 versions earlier than PAN-OS 8.1.16; PAN-OS 9.0 versions earlier than PAN-OS 9.0.9.
Affected products
- Palo Alto Networks PAN-OS: from 8.1.0 before 8.1.16; from 9.0.0 before 9.0.9 — fixed in 8.1.16, 9.0.9
- Palo Alto Networks PAN-OS: from 9.0 before 9.0.9; from 8.1 before 8.1.16 — fixed in 9.0.9, 8.1.16
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 8.1.16, 9.0.9; Palo Alto Networks PAN-OS 9.0.9, 8.1.16. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2020-2036
- https://security.paloaltonetworks.com/CVE-2020-2036
Get alerted when CVE-2020-2036 or the next vulnerability affects your stack