What’s Vulnerable › Vulnerabilities
CVE-2020-2037: PAN-OS: OS command injection vulnerability in the management web interface
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-09-09 · updated 2026-06-17
- Weakness: CWE-78
Description
An OS Command Injection vulnerability in the PAN-OS management interface that allows authenticated administrators to execute arbitrary OS commands with root privileges. This issue impacts: PAN-OS 8.1 versions earlier than PAN-OS 8.1.16; PAN-OS 9.0 versions earlier than PAN-OS 9.0.10; PAN-OS 9.1 versions earlier than PAN-OS 9.1.3.
Affected products
- Palo Alto Networks PAN-OS: from 8.1.0 before 8.1.16; from 9.0.0 before 9.0.10; from 9.1.0 before 9.1.3 — fixed in 8.1.16, 9.0.10, 9.1.3
- Palo Alto Networks PAN-OS: from 8.1 before 8.1.16; from 9.0 before 9.0.10; from 9.1 before 9.1.3 — fixed in 8.1.16, 9.0.10, 9.1.3
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 8.1.16, 9.0.10, 9.1.3; Palo Alto Networks PAN-OS 8.1.16, 9.0.10, 9.1.3. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2020-2037
- https://security.paloaltonetworks.com/CVE-2020-2037
Get alerted when CVE-2020-2037 or the next vulnerability affects your stack