What’s Vulnerable › Vulnerabilities
CVE-2020-2038: PAN-OS: OS command injection vulnerability in the management web interface
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 86.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-09-09 · updated 2026-06-17
- Weakness: CWE-78
Description
An OS Command Injection vulnerability in the PAN-OS management interface that allows authenticated administrators to execute arbitrary OS commands with root privileges. This issue impacts: PAN-OS 9.0 versions earlier than 9.0.10; PAN-OS 9.1 versions earlier than 9.1.4; PAN-OS 10.0 versions earlier than 10.0.1.
Affected products
- Palo Alto Networks PAN-OS: from 9.0.0 before 9.0.10; from 9.1.0 before 9.1.4; from 10.0.0 before 10.0.1 — fixed in 9.0.10, 9.1.4, 10.0.1
- Palo Alto Networks PAN-OS: from 10.0 before 10.0.1; from 9.0 before 9.0.10; from 9.1 before 9.1.4 — fixed in 10.0.1, 9.0.10, 9.1.4
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 9.0.10, 9.1.4, 10.0.1; Palo Alto Networks PAN-OS 10.0.1, 9.0.10, 9.1.4. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/168008/PAN-OS-10.0-Remote-Code-Execution.html
- http://packetstormsecurity.com/files/168408/Palo-Alto-Networks-Authenticated-Remote-Code-Execution.html
- https://security.paloaltonetworks.com/CVE-2020-2038
- http://packetstormsecurity.com/files/168008/PAN-OS-10.0-Remote-Code-Execution.html
- http://packetstormsecurity.com/files/168408/Palo-Alto-Networks-Authenticated-Remote-Code-Execution.html
- https://security.paloaltonetworks.com/CVE-2020-2038
Get alerted when CVE-2020-2038 or the next vulnerability affects your stack