What’s Vulnerable › Vulnerabilities

CVE-2020-2040: PAN-OS: Buffer overflow when Captive Portal or Multi-Factor Authentication (MFA) is enabled

Description

A buffer overflow vulnerability in PAN-OS allows an unauthenticated attacker to disrupt system processes and potentially execute arbitrary code with root privileges by sending a malicious request to the Captive Portal or Multi-Factor Authentication interface. This issue impacts: All versions of PAN-OS 8.0; PAN-OS 8.1 versions earlier than PAN-OS 8.1.15; PAN-OS 9.0 versions earlier than PAN-OS 9.0.9; PAN-OS 9.1 versions earlier than PAN-OS 9.1.3.

Affected products

How to fix

Upgrade to a fixed version: Palo Alto Networks PAN-OS 8.1.15, 9.0.9, 9.1.3; Palo Alto Networks PAN-OS 9.0.9, 9.1.3, 8.1.15. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-2040 or the next vulnerability affects your stack