What’s Vulnerable › Vulnerabilities
CVE-2020-2042: PAN-OS: Buffer overflow in the management web interface
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-09-09 · updated 2026-06-17
- Weakness: CWE-121
Description
A buffer overflow vulnerability in the PAN-OS management web interface allows authenticated administrators to disrupt system processes and potentially execute arbitrary code with root privileges. This issue impacts only PAN-OS 10.0 versions earlier than PAN-OS 10.0.1.
Affected products
- Palo Alto Networks PAN-OS: from 10.0.0 before 10.0.1 — fixed in 10.0.1
- Palo Alto Networks PAN-OS: from 10.0 before 10.0.1 — fixed in 10.0.1
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 10.0.1; Palo Alto Networks PAN-OS 10.0.1. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2020-2042
- https://security.paloaltonetworks.com/CVE-2020-2042
Get alerted when CVE-2020-2042 or the next vulnerability affects your stack