What’s Vulnerable › Vulnerabilities
CVE-2020-2050: PAN-OS: Authentication bypass vulnerability in GlobalProtect SSL VPN client certificate verification
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-11-12 · updated 2026-06-17
- Weakness: CWE-285
Description
An authentication bypass vulnerability exists in the GlobalProtect SSL VPN component of Palo Alto Networks PAN-OS software that allows an attacker to bypass all client certificate checks with an invalid certificate. A remote attacker can successfully authenticate as any user and gain access to restricted VPN network resources when the gateway or portal is configured to rely entirely on certificate-based authentication. Impacted features that use SSL VPN with client certificate verification are: GlobalProtect Gateway, GlobalProtect Portal, GlobalProtect Clientless VPN In configurations where client certificate verification is used in conjunction with other authentication methods, the protections added by the certificate check are ignored as a result of this issue. This issue impacts: PAN-OS 8.1 versions earlier than PAN-OS 8.1.17; PAN-OS 9.0 versions earlier than PAN-OS 9.0.11; PAN-OS 9.1 versions earlier than PAN-OS 9.1.5; PAN-OS 10.0 versions earlier than PAN-OS 10.0.1.
Affected products
- Palo Alto Networks PAN-OS: from 8.1.0 before 8.1.17; from 9.0.0 before 9.0.11; from 9.1.0 before 9.1.5; from 10.0.0 before 10.0.1 — fixed in 8.1.17, 9.0.11, 9.1.5, 10.0.1
- Palo Alto Networks PAN-OS: from 8.1 before 8.1.17; from 9.0 before 9.0.11; from 9.1 before 9.1.5; from 10.0 before 10.0.1 — fixed in 8.1.17, 9.0.11, 9.1.5, 10.0.1
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 8.1.17, 9.0.11, 9.1.5, 10.0.1; Palo Alto Networks PAN-OS 8.1.17, 9.0.11, 9.1.5, 10.0.1. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2020-2050
- https://security.paloaltonetworks.com/CVE-2020-2050
Get alerted when CVE-2020-2050 or the next vulnerability affects your stack